Wing Commander – Alliance – Running in the 1.95

Wing Commander – Alliance – Running in the 1.95

Some people asked me if this mod runs in the last 1.95. The answer is yes but remember, the mod requires the original game + all the DLC, they are Forbidden Worlds, Stellar Phenomena, Outlaw Sectors and Minor Factions. Without them, you will see errors.

And remember, the game has very big maps with many players, but you must play things which you can play in your computer and avoid big things because it is a old game with a mod. It is a good recomendation.

Leave a Reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.